AddRule Method (RoutingPreferenceRuleGroupType, RoutingPreferenceRule)


Routing Preference Manager Add Rule(Routing Preference Rule Group Type, Routing Preference Rule) Method

Adds a new routing preference rule to the rule group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddRule(
	RoutingPreferenceRuleGroupType groupType,
	RoutingPreferenceRule rule
)

Parameters

groupType RoutingPreferenceRuleGroupType
The routing preference group in which the rule should be added.
rule RoutingPreferenceRule
The new rule to be added.
Exceptions
Exception Condition
ArgumentException The rule cannot be added to the groupType. -or- Thrown if the index is out of bounds, or the rule is not valid for this group (e.g. an elbow may not be added to the junction group).
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also