GetLapLength Method


Rebar Bar Type Get Lap Length Method

Gets the lap length taking into account the specified Rebar Splice Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetLapLength(
	ElementId rebarSpliceTypeId
)

Parameters

rebarSpliceTypeId ElementId
The Rebar Splice Type id. Interactions with Rebar Splice Types can be done with the functions in RebarSpliceTypeUtils .

Return Value

Double
Returns the lap length.
Exceptions
Exception Condition
ArgumentException The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
ArgumentNullException A non-optional argument was null
See Also