Insulation |
Returns the ids of the insulation elements associated to a given element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ICollection<ElementId> GetInsulationIds(
Document document,
ElementId elemId
)
Parameters
Return Value
ICollection ElementIdA collection of the ids of the insulation elements.

Exception | Condition |
---|---|
ArgumentException | This id does not represent a valid host for insulation. |
ArgumentNullException | A non-optional argument was null |