ExternallyTaggedGeometryValidation Class


Externally Tagged Geometry Validation Class

Provides validation for geometry to be stored in an ExternallyTaggedGeometry.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternallyTaggedGeometryValidation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ExternallyTaggedGeometryValidation

The ExternallyTaggedGeometryValidation type exposes the following members.

Methods
Name Description
Public method Static member IsNonSolid Makes sure that the input geometry object is not a Solid.
Public method Static member IsSolid Makes sure that the input geometry object is a Solid.
Public method Static member LacksSubnodes Makes sure that the input geometry object does not have sub-nodes.
Top
See Also