Create Method


HVACLoad Building Type Create Method

Creates a building type element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static HVACLoadBuildingType Create(
	Document document,
	string name
)

Parameters

document Document
The document.
name String
The building type name.

Return Value

HVACLoadBuildingType
The new building type.
Exceptions
Exception Condition
ArgumentException name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as a building type name.
ArgumentNullException A non-optional argument was null
See Also