MinimumDigits Property


Numeric Revision Settings Minimum Digits Property

Controls the minimum number of digits for a revision number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int MinimumDigits { get; set; }

Property Value

Int32
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: The given value for minimumDigits is not positive.
Remarks
Use MinimumDigits to force the minimum number of digits for a revision number. Zeros will be added to the front of the revision number until the minimum number of digits is satisfied. For example, if MinimumDigits is 3, then 9 will be printed as 009 and 10 will be printed as 010. If MinimumDigits is 1, then no zeros are added to the front of the revision number. The default value for MinimumDigits is 1. Values less than 1 are not allowed.
See Also