RemoveEndReference Method


Structural Framing Utils Remove End Reference Method

Resets the end reference of the structural framing element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void RemoveEndReference(
	FamilyInstance familyInstance,
	int end
)

Parameters

familyInstance FamilyInstance
The FamilyInstance, which must be of a structural framing category, non-concrete and joined.
end Int32
The index of the end (0 for the start, 1 for the end).
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException end must be 0 or 1.
ArgumentsInconsistentException The input familyInstance is not of a structural framing category or is concrete or is not joined at given end and cannot have an end reference set.
Remarks
The setback value will be changed as a result of the removal.
See Also