NewFlexDuct Method (Connector, IList(XYZ), FlexDuctType)


Document New Flex Duct(Connector, IList XYZ , Flex Duct Type) Method

Adds a new flexible duct into the document, using a connector, point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FlexDuct NewFlexDuct(
	Connector connector,
	IList<XYZ> points,
	FlexDuctType ductType
)

Parameters

connector Connector
The connector to be connected to the duct, including the end points.
points IList XYZ
The point array indicating the path of the flexible duct.
ductType FlexDuctType
The type of the flexible duct.

Return Value

FlexDuct
If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input argument connector or points is .
InvalidOperationException Thrown when the flexible duct cannot be created or regenerate fails.
ArgumentException Thrown if the flexible duct type does not exist in the given document.
Remarks
If the connector is a fitting or equipment connector of the correct domain, and if the connector's direction matches the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.
See Also