Rebar |
Sets the lap length for the specified Rebar Splice Type.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- rebarSpliceTypeId ElementId
- The Rebar Splice Type id. Interactions with Rebar Splice Types can be done with the functions in RebarSpliceTypeUtils .
- lapLength Double
- The new value of the lap length.

Exception | Condition |
---|---|
ArgumentException | The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category. -or- For the specified Rebar Splice Type the lap length is auto calculated and the lap length cannot be manually set. Its value is computed based on the formula splice type: lap length multiplier * bar nominal diameter. |
ArgumentNullException | A non-optional argument was null |