LinkedFileStatus Enumeration


Linked File Status Enumeration

Enum displaying the loaded status of a linked file

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum LinkedFileStatus
Members
Member name Value Description
Loaded 0 The link is loaded.
Unloaded 1 The link is unloaded.
Imported 2 The element represented by this value was imported into Revit rather than linked into Revit.
NotFound 3 The linked file was not able to be found the last time Revit tried to load it.
CanBeUpgraded 4 The linked point cloud file is obsolete and can be indexed into new format.
InClosedWorkset 5 The linked file is in a closed workset and will not be displayed.
LocallyUnloaded 6 The linked file is unloaded for the specific user. (If the linked file is both unloaded for the specific user and unloaded for all users, the link will report LinkedFileStatus.Unloaded.)
Invalid -1 This value is the uninitialized value for the enum. It indicates that the link has not been properly initialized.
See Also