ModuleSettings Constructor


Module Settings Constructor

Constructs a new module settings.

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ModuleSettings(
	string name,
	MacroLanguageType macroLanguageType
)

Parameters

name String
The module name.
macroLanguageType MacroLanguageType
The Macro language type.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also