Shape |
Sets the length unit to be used when the input is a unitless SAT file.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- defaultLengthUnit ImportUnit
- The length unit to be used for when the input is a unitless SAT file.
Return Value
ShapeImporter
Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

Values ImportUnit::Default and ImportUnit::Custom are ignored. ImportUnit::Centimeter is used instead.