Filtered |
Applies an element filter to the collector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- filter ElementFilter
- The element filter.
Return Value
FilteredElementCollectorA handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The filter will be added as an additional condition that all filtered elements must pass. If you have an active iterator to this collector it will be stopped by this call.