SetMinorLayoutAsFixedNumber Method


Fabric Sheet Type Set Minor Layout As Fixed Number Method

Sets the major layout pattern as FixedNumber, while specifying the needed parameters for this pattern.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMinorLayoutAsFixedNumber(
	double overallLength,
	double majorStartOverhang,
	double majorEndOverhang,
	int numberOfWires
)

Parameters

overallLength Double
The entire length of the wire sheet in the major direction.
majorStartOverhang Double
The distance from the edge of the sheet to the first wire in the major direction.
majorEndOverhang Double
The distance from the last wire to the edge of the sheet in the major direction.
numberOfWires Int32
The number of the wires to set in the minor direction.
Exceptions
Exception Condition
ArgumentException The given value for overallLength is not a number -or- The given value for majorStartOverhang is not a number -or- The given value for majorEndOverhang is not a number -or- numberOfWires must range from 2 to 1000000. -or- The arguments are not consistent, please specify proper input values.
ArgumentOutOfRangeException The given value for overallLength must be greater than 0 and no more than 30000 feet. -or- The given value for majorStartOverhang must be between 0 and 30000 feet. -or- The given value for majorEndOverhang must be between 0 and 30000 feet.
See Also