DocumentCreatingEventArgs Class


Document Creating Event Args Class

The event arguments used by the DocumentCreating event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DocumentCreatingEventArgs : RevitAPIPreEventArgs

The DocumentCreatingEventArgs type exposes the following members.

Properties
Name Description
Public property DocumentType Type of the document which is about to be created, e.g. Project or Template.
Public property Template The template file path to be used for creating the new document.
Top
Methods
Name Description
Top
See Also