BuiltInFailures.ViewSheetFailures Class


Built In Failures View Sheet Failures Class

Failures about placing viewports on sheets.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures ViewSheetFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ViewSheetFailures

The BuiltInFailures ViewSheetFailures type exposes the following members.

Properties
Name Description
Public property Static member ViewInAModelMustBeUnique Sheet views in this model cannot contain more than one instance of "%1!s!."
Public property Static member ViewInAModelMustBeUniqueWarn Sheet views in this model cannot contain more than one instance of "%1!s!."
Public property Static member ViewOnASheetCannotBeUncropped3DPerspectiveView Sheets do not support uncropped perspective views.
Public property Static member ViewOnASheetMustBeUnique Sheet views cannot contain more than one instance of "%1!s!."
Public property Static member ViewOnASheetMustBeUniqueWarn Sheet views cannot contain more than one instance of "%1!s!."
Public property Static member ViewportCantContainEmptyView Sheet views cannot contain empty view "%1!s!".
Top
See Also