StructuralSectionUtils Class


Structural Section Utils Class

This class provides utilities related to Structural Section Properties.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionUtils

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class StructuralSectionUtils

The StructuralSectionUtils type exposes the following members.

Methods
Name Description
Public method Static member GetStructuralElementDefinitionData Return structural element definition data.
Public method Static member GetStructuralSection Return structural section from element.
Public method Static member SetStructuralSection Set structural section in element.
Top
See Also