Effect |
An effect instance that controls the appearance of geometry.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The EffectInstance type exposes the following members.

Name | Description | |
---|---|---|
![]() | EffectInstance | Constructs the effect instance for geometry having the specified vertex format. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the EffectInstance |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsValid | Tests whether the effect instance is valid for rendering. |
![]() | MatchesFormat | Tests whether the effect instance is appropriate for the given vertex format. |
![]() | SetAmbientColor | Sets the ambient color parameter of the effect instance. |
![]() | SetColor | Sets the color parameter of the effect instance. |
![]() | SetDiffuseColor | Sets the diffuse color parameter of the effect instance. |
![]() | SetEmissiveColor | Sets the emissive color parameter of the effect instance. |
![]() | SetGlossiness | Sets the glossiness parameter of the effect instance. |
![]() | SetSpecularColor | Sets the specular color parameter of the effect instance. |
![]() | SetTransparency | Sets the transparency parameter of the effect instance. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Each effect instance should be used with geometry of a matching vertex format. Only a subset of effect instance parameters is relevant to geometry of a particular vertex format. If the vertex format does not specify vertex color ( VertexPosition or VertexPositionNormal ) the following parameters should be set: If the vertex format specifies vertex normals ( VertexPositionNormal or VertexPositionNormalColored ) the following parameters should be set: If the vertex format specifies a color, then the geometry will be colored according to the color of each vertex. Otherwise, the geometry's color will come from the effect instance parameters. Similarly, the transparency parameter affects all of the geometry associated with the effect, while the transparency of the individual vertices can also be controlled via the transparency component of their colors.