ViewExportingEventArgs Class


View Exporting Event Args Class

The event arguments used by the ViewExporting event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewExportingEventArgs : RevitAPIPreDocEventArgs

The ViewExportingEventArgs type exposes the following members.

Properties
Name Description
Public property Cancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs )
Public property Document The document associated with the event.
(Inherited from RevitAPIPreDocEventArgs )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs )
Public property ViewId Identifies the view about to be exported.
Top
Methods
Name Description
Public method Cancel When the event is cancellable, may call the Cancel() method to cancel it.
(Inherited from RevitAPIPreEventArgs )
Public method Dispose
(Inherited from RevitAPIEventArgs )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also