Design |
Converts the set of MEP design elements into fabrication parts.
Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public DesignToFabricationConverterResult Convert(
ISet<ElementId> selection,
int serviceId
)
Parameters
- selection ISet ElementId
- The set of element identifiers to convert from MEP design elements to fabrication parts.
- serviceId Int32
- The identifier of the fabrication service.
Return Value
DesignToFabricationConverterResult
Exception | Condition |
---|---|
ArgumentException | the selection contains invalid elements to convert. -or- the specified fabrication service is not valid for all domains in the selection. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | no fabrication configuration is loaded. |

After this method has been invoked, call:
- GetConvertedFabricationParts to get a set of element identifiers for the newly created fabrication parts.
- GetElementsWithOpenConnector to get a set of fabrication part or MEP design element identifiers with open connectors, caused by fittings failing to convert.