CableTraySizeIterator Class


Cable Tray Size Iterator Class

An iterator to a set of MEP cable tray sizes from CableTraySizes.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical CableTraySizeIterator

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CableTraySizeIterator : IEnumerator<MEPSize>

The CableTraySizeIterator type exposes the following members.

Properties
Name Description
Public property Current Gets the item at the current position of the iterator.
Protected property CurrentObject
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the CableTraySizeIterator
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetCurrent Returns the current MEPSize.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method HasCurrent Identifies if the iterator has a current item.
Public method IsDone Identifies if the iteration has completed.
Public method MoveNext Increments the iterator to the next item.
Public method Reset Resets the iterator to the initial state.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also