GetWrappingLocationAsCurveParameter Method


Wall Get Wrapping Location As Curve Parameter Method

Gets the non-normalized (actual) curve parameter of the location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetWrappingLocationAsCurveParameter(
	int locationIndex
)

Parameters

locationIndex Int32
0 or 1 represents wall's end, other number represents the wrapping locations on vertical faces of openings or profiles.

Return Value

Double
The non-normalized (actual) curve parameter value on the curve.
Exceptions
Exception Condition
ArgumentException This location is invalid for wrapping.
Remarks
If the location is invalid, for example: wall doesn't have this location or the location is joined, this function throws ArgumentException.
See Also