ConnectDuctPlaceholdersAtCross Method (Document, ElementId, ElementId, ElementId)


Mechanical Utils Connect Duct Placeholders At Cross(Document, Element Id, Element Id, Element Id) Method

Connects a trio of placeholders that can intersect in a Cross connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool ConnectDuctPlaceholdersAtCross(
	Document document,
	ElementId placeholder1Id,
	ElementId placeholder2Id,
	ElementId placeholder3Id
)

Parameters

document Document
The document.
placeholder1Id ElementId
The element id of the first duct placeholder.
placeholder2Id ElementId
The element id of the second duct placeholder.
placeholder3Id ElementId
The element id of third duct placeholder.

Return Value

Boolean
True if connection succeeds, false otherwise.
Exceptions
Exception Condition
ArgumentException The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The element id placeholder3Id is not duct placeholder. -or- The elements belong to different types of system. -or- The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa. -or- The curve placeholder3Id does not connect on the curve placeholder1Id or vice versa. -or- The curve placeholder2Id and placeholder3Id are not collinear.
ArgumentNullException A non-optional argument was null
Remarks
If connection fails, the placeholders cannot be physically connected.
See Also