Rebar |
A specification for a simple 3D rebar shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarShapeMultiplanarDefinition type exposes the following members.

Name | Description | |
---|---|---|
![]() | RebarShapeMultiplanarDefinition | Create a RebarShapeMultiplanarDefinition for use in creating a RebarShape. |

Name | Description | |
---|---|---|
![]() | DepthParamId | Id of the parameter driving the multiplanar depth. The depth is measured center-to-center of the bar. A valid shape parameter must be assigned to DepthParamId before the MultiplanarDefinition can be used in RebarShape creation. |
![]() | IsDuplicateShapePresent | Whether the shape definition includes an offset copy of the 2D shape. |
![]() | IsEndConnectorPresent | Whether a perpendicular segment is constructed from the end of the 2D shape. |
![]() | IsStartConnectorPresent | Whether a perpendicular segment is constructed from the start of the 2D shape. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | OutOfPlaneBendDiameter | Bend diameter to be applied to the connector segments. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the RebarShapeMultiplanarDefinition |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetPresenceOfSegments | Simultaneously set the presence of all 3D segments. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Simple 3D rebar shapes are supported by adding segments to a regular 2D shape definition. The added segments consist of three optional parts: a "duplicate shape" and two connectors. A "duplicate shape" is a second copy of the 2D shape, offset in a perpendicular direction, and connected at either the start or the end by a perpendicular connector segment. Also supported is adding one or both connector segments, without the duplicate shape. Fillets are applied to the connector segments with a diameter that is given by the OutOfPlaneBendDiameter property. The length of the connectors is given by the Rebar instance parameter "multiplanar depth." The MultiplanarDepth property of this class is the default value of the parameter.