Image |
If true the ImageTypeOptions can be used to create or reload an ImageType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- The document.
Return Value
BooleanReturns True if the options can be used to create or reload an ImageType. False otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This method returns true if all the following checks are true:
- The Path points to a file that is a supported image file type.
- The Path points to a file that is not encrypted, which can happen for PDF files.
- The Path points to a file that contains the specified PageNumber.
- Only imported images are allowed in family documents.