PointCloudOverrideSettings Class


Point Cloud Override Settings Class

The graphic override settings for one PointCloudInstance element or one of its scans.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.PointClouds PointCloudOverrideSettings

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointCloudOverrideSettings : IDisposable

The PointCloudOverrideSettings type exposes the following members.

Constructors
Name Description
Public method PointCloudOverrideSettings Constructs a settings object with default values.
Public method PointCloudOverrideSettings(PointCloudOverrideSettings) Constructs a copy of source object.
Top
Properties
Name Description
Public property ColorMode The current color mode for the PointCloudInstance element or its scan.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Visible Visibility flag for point cloud scans.
Top
Methods
Name Description
Public method Assign Assigns values of the source settings to this object.
Public method Dispose Releases all resources used by the PointCloudOverrideSettings
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetModeOverride Lookup color settings for the given color mode.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsEqual Checks if the contents of two settings are equal.
Public method SetModeOverride Sets color settings for the given color mode.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also