AddHosts Method


Rebar Bending Detail Add Hosts Method

Adds the reinforcement elements that will be represented by the input bending detail.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void AddHosts(
	Element bendingDetail,
	IList<Reference> references
)

Parameters

bendingDetail Element
The bending detail for which we want to set the host.
references IList Reference
Reference pointing to the reinforcement element that will be represented by the input bending detail.
Exceptions
Exception Condition
ArgumentException -or- This option is only available for schematic bending detail elements.
ArgumentNullException A non-optional argument was null
See Also