GetRegionsAlongLevel Method


Compound Structure Get Regions Along Level Method

Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<int> GetRegionsAlongLevel(
	double height
)

Parameters

height Double
Distance from the bottom of the wall.

Return Value

IList Int32
The ids of the regions intersected by the specified line.
Exceptions
Exception Condition
ArgumentException The height is outside valid range. It should be in the range of [0, SampleHeight].
See Also