BuiltInFailures.GridFailures Class


Built In Failures Grid Failures Class

Failures about Grid.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures GridFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class GridFailures

The BuiltInFailures GridFailures type exposes the following members.

Properties
Name Description
Public property Static member GridEndSegmentsLengthTooShort The end segment length for a grid must be at least [Length Value]
Public property Static member GridInGridChainCannotMirror A grid that is a sub-grid of a multi-segment grid can only be mirrored if the entire multi-segment grid is being mirrored.
Public property Static member GridlineAxisTooClose Axis of gridlines should not change order or be closer than [Value] to each other.
Public property Static member GridlineAxisTooFar Axis of gridlines should not be further than [Value] to each other.
Top
See Also