Form Class


Form Class

An object that represents a Form within the Autodesk Revit Massing Family.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Form : GenericForm

The Form type exposes the following members.

Properties
Name Description
Public property AreProfilesConstrained Get/set if the form's profiles are constrained.
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element )
Public property BaseOffset Retrieve/set the base offset of the form object. It is only valid for locked form.
Public property Code example BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element )
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element )
Public property Combinations The geometry combinations that this element belongs to.
(Inherited from CombinableElement )
Public property Code example CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element )
Public property CurveLoopReferencesOnProfile The curve references in certain curve loop, specified by profile index and curve loop index.
Public property Code example DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element )
Public property Code example DesignOption Returns the design option to which the element belongs.
(Inherited from Element )
Public property Document Returns the Document in which the Element resides.
(Inherited from Element )
Public property Code example Geometry Retrieves the geometric representation of the element.
(Inherited from Element )
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element )
Public property HasOneOrMoreReferenceProfiles Tell if the form has any reference profile.
Public property HasOpenGeometry Tell if the form has an open geometry.
Public property Code example Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element )
Public property IsInXRayMode Get/set if the form is in X-Ray mode.
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element )
Public property IsSolid Identifies if the GenericForm is a solid or a void element.
(Inherited from GenericForm )
Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element )
Public property LevelId The id of the level associated with the element.
(Inherited from Element )
Public property Code example Location This property is used to find the physical location of an element within a project.
(Inherited from Element )
Public property Name Get and Set the Name property
(Inherited from GenericForm )
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element )
Public property Code example Parameter BuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element )
Public property Parameter Definition Retrieves a parameter from the element based on its definition.
(Inherited from Element )
Public property Parameter Guid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element )
Public property Code example Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property PathCurveCount The number of curves in the form path.
Public property PathCurveReference The curve reference in the path, specified by curve index.
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element )
Public property ProfileCount The number of profiles in the form.
Public property ProfileCurveLoopCount The number of curve loops in certain profile, specified by profile index.
Public property Subcategory The subcategory.
(Inherited from GenericForm )
Public property TopOffset Retrieve/set the top offset of the form object. It is only valid for locked form.
Public property Code example UniqueId A stable unique identifier for an element within the document.
(Inherited from Element )
Public property VersionGuid Get the element version Guid.
(Inherited from Element )
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element )
Public property Visible The visibility of the GenericForm.
(Inherited from GenericForm )
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element )
Top
Methods
Name Description
Public method AddEdge(Reference, Reference) Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method AddEdge(Reference, XYZ) Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method AddEdge(Reference, Double, Reference, Double) Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.
Public method AddProfile Add a profile into the form, by a specified edge/param.
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element )
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element )
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element )
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element )
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element )
Public method CanManipulateProfile Tell if a profile can be deleted/moved/rotated.
Public method CanManipulateSubElement Tell if a sub element can be deleted/moved/rotated/scaled.
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element )
Public method ConstrainProfiles Constrain form profiles using the specified profile as primary. This is an advanced version of property "AreProfilesConstrained", allowing specify the primary profile.
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element )
Public method DeleteProfile Delete a profile of the form.
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element )
Public method DeleteSubElement Delete a face/edge/curve/vertex of the form, specified by a reference.
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element )
Public method Dispose
(Inherited from Element )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element )
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element )
Public method GetControlPoints Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
Public method GetCurvesAndEdgesReference Given a point, return all edges and curves that it is lying on.
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element )
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element )
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element )
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element )
Public method Code example GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element )
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element )
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element )
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element )
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element )
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element )
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element )
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element )
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element )
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element )
Public method GetPathCurveIndexByCurveReference Given a reference to certain curve in the path, return its index.
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element )
Public method GetProfileAndCurveLoopIndexFromReference Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Code example GetTypeId Returns the identifier of this element's type.
(Inherited from Element )
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element )
Public method GetVisibility Gets the visibility for the generic form.
(Inherited from GenericForm )
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element )
Public method IsAutoCreaseEdge Tell if an edge is an auto-crease on a top/bottom cap face.
Public method IsBeginningFace Given a face, tell if it is a beginning cap face.
Public method IsConnectingEdge Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsCurveReference Tell if the pick is the reference to a curve of the form.
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsEdgeReference Tell if the pick is the reference to an edge of the form.
Public method IsEndFace Given a face, tell if it is an end cap face.
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element )
Public method IsFaceReference Tell if the pick is the reference to a face of the form.
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element )
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element )
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element )
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element )
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element )
Public method IsProfileEdge Tell if an edge or curve is generated from a profile.
Public method IsReferenceOnlyProfile Tell if the profile is made by referencing existing geometry in the Revit model.
Public method IsSideFace Given a face, tell if it is a side face.
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element )
Public method IsVertexReference Tell if the pick is the reference to a vertex of the form.
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element )
Public method Code example MoveProfile Move a profile of the form, specified by a reference, and an offset vector.
Public method Code example MoveSubElement Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element )
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element )
Public method Rehost(Reference, XYZ) Rehost Form to edge, face or curve.
Public method Rehost(SketchPlane, XYZ) Rehost Form to sketch plane
Public method RotateProfile Rotate a profile of the form, by a specified angle around a given axis.
Public method RotateSubElement Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
Public method ScaleProfile Scale a profile of the form, by a specified origin and scale factor.
Public method ScaleSubElement Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element )
Public method SetVisibility Sets the visibility for the generic form.
(Inherited from GenericForm )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
For any reference returned from a Form method, its GeometryObject will become invalid after a form modification method, e.g. MoveSubElement. Call the method on the Form object to retrieve the new reference if it is needed after the modification.
See Also