GetFloorOrSlabConstructionType Method


Conceptual Construction Type Get Floor Or Slab Construction Type Method

Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId GetFloorOrSlabConstructionType(
	Document ccda,
	ConceptualConstructionFloorSlabType typeEnum
)

Parameters

ccda Document
The Document.
typeEnum ConceptualConstructionFloorSlabType
The ConceptualConstructionFloorSlabType to get the ConceptualConstructionType for.

Return Value

ElementId
Returns ElementId of a ConceptualConstructionType.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The enum is invalid for ConceptualConstructionFloorSlabType. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also