SetStaggerLengthMultiplier Method


Rebar Splice Type Utils Set Stagger Length Multiplier Method

Sets the lap length multiplier value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void SetStaggerLengthMultiplier(
	Document document,
	ElementId rebarSpliceTypeId,
	double staggerLengthMultiplier
)

Parameters

document Document
The document.
rebarSpliceTypeId ElementId
The Rebar Splice Type id.
staggerLengthMultiplier Double
The stagger multiplier value.
Exceptions
Exception Condition
ArgumentException The rebarSpliceTypeId doesn't represent a valid Rebar Splice Type. It should be an ElementType of BuiltInCategory.OST_RebarSpliceType category.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for staggerLengthMultiplier must be non-negative.
See Also