GetElementIds Method


Selection Get Element Ids Method

Returns the ids of the elements that are currently selected within the project. The selection may not be complete. See GetReferences for more options.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ICollection<ElementId> GetElementIds()

Return Value

ICollection ElementId
The collection containing the ids of the selected elements.
See Also