Rebar |
This function calculates the lap direction given a RebarSpliceGeometry and a RebarSplicePosition.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static XYZ GetLapDirectionForSpliceGeometryAndPosition(
Rebar rebar,
RebarSpliceGeometry spliceGeometry,
RebarSplicePosition splicePosition
)
Parameters
- rebar Rebar
- The input rebar.
- spliceGeometry RebarSpliceGeometry
- The splice geometry.
- splicePosition RebarSplicePosition
- The splice position.
Return Value
XYZThe lap direction.

Exception | Condition |
---|---|
ArgumentException | RebarSplicePosition should not be Middle. -or- The rebar cannot be spliced with the provided RebarSpliceGeometry. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

This function determines first the point where the RebarSpliceGeometry will cut the rebar. Based on the RebarSplicePosition value it will determine the direction where the lap will go, RebarSplicePosition.End1 meaning towards the start of the splice chain and RebarSplicePosition.End2 towards the end. For more information about the splice chain concept please check Autodesk.Revit.DB.Structure.RebarSpliceUtils.GetSpliceChain(Rebar rebar). This function will throw exception if it's called with RebarSplicePosition.Middle.