ShowElements Method (ICollection(ElementId))


UIDocument Show Elements(ICollection Element Id ) Method

Shows the elements by zoom to fit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ShowElements(
	ICollection<ElementId> elementIds
)

Parameters

elementIds ICollection ElementId
The set of element ids which will be shown.
Exceptions
Exception Condition
ArgumentNullException elementIds is null.
ArgumentException Member of elementIds is null.
ArgumentException Member of elementIds is not valid.
Remarks
Places all the elements on the screen by moving the view.
See Also