Direct |
Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- pGeomArr IList GeometryObject
- Shape expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.

Exception | Condition |
---|---|
ArgumentException | At least one member of pGeomArr does not satisfy DirectShapeType validation criteria. |
ArgumentNullException | A non-optional argument was null |

The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.