ExternalFileReferenceType Enumeration


External File Reference Type Enumeration

Enum class indicating kinds of external file references

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ExternalFileReferenceType
Members
Member name Value Description
None 0 Uninitialized value
RevitLink 1 Revit linked files
CADLink 2 Linked CAD files
DWFMarkup 3 DWF markup files
KeynoteTable 4 The keynote table (The file which contains keynote information.)
Decal 5 Decals (images which appear only during rendering)
Material 6 Materials are not included as ExternalFileReferences in the 2012 release
AssemblyCodeTable 7 The assembly code table (The file which contains assembly code information.)
SystemsAnalysisReport 12 Systems analysis report file path
See Also