Binding |
The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB DefinitionBindingMap
Autodesk.Revit.DB BindingMap
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB DefinitionBindingMap
Autodesk.Revit.DB BindingMap
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The BindingMap type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap ) |
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |
![]() | Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap Item Definition ) |
![]() | Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap ) |

Name | Description | |
---|---|---|
![]() | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap Clear ) |
![]() | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap Contains(Definition) ) |
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap Erase(Definition) ) |
![]() | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap ) |
![]() | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMap Insert(Definition, Binding) ) |
![]() | Insert(Definition, Binding, ForgeTypeId) | Creates a new parameter binding between a parameter and a set of categories in a specified group. |
![]() | ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter. |
![]() | ReInsert(Definition, Binding, ForgeTypeId) | Removes an existing parameter and creates a new binding for a given parameter in a specified group. |
![]() | Remove | The Remove method is used to remove a parameter binding. |
![]() | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The ParameterBindingsMap is available from the Document.ParameterBindings property. A parameter binding is the way that a parameter definition is bound to elements within one or more categories. This map can be used to interrogate existing bindings, but it can also be used to generate new parameter bindings by using the Insert method.