FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)


Family Instance Creation Data(XYZ, Family Symbol, Element, Level, Structural Type) Constructor

Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyInstanceCreationData(
	XYZ location,
	FamilySymbol symbol,
	Element host,
	Level level,
	StructuralType structuralType
)

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host Element
The object into which the FamilyInstance is to be inserted, often known as the host.
level Level
A Level object that is used as the base level for the object.
structuralType StructuralType
If structural then specify the type of the component.
See Also