TrussMemberInfo Class


Truss Member Info Class

Provides access to the information of a truss member in Autodesk Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure TrussMemberInfo

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TrussMemberInfo

The TrussMemberInfo type exposes the following members.

Constructors
Name Description
Public method TrussMemberInfo For Internal Use Only.
Top
Properties
Name Description
Public property hostTrussId The host truss' ElementId of the member.
Public property lockedToTruss Whether the member is locked to the host truss.
Public property memberTypeKey Kind of the member in the truss.
Top
Methods
Name Description
Top
Remarks
A struct TrussMemberInfo that contains an element's host truss, whether to lock to the truss, usage type, etc.
See Also