Selectable |
A filter that passes elements that are selectable in the given view.

System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.UI.Selection SelectableInViewFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.UI.Selection SelectableInViewFilter
Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The SelectableInViewFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | SelectableInViewFilter(Document, ElementId) | Constructs a new instance of an SelectableInViewFilter. |
![]() | SelectableInViewFilter(Document, ElementId, Boolean) | Constructs a new instance of an SelectableInViewFilter, with the option to pass all non-selectable elements. |

Name | Description | |
---|---|---|
![]() | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ElementFilter ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from ElementFilter ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter ) |
![]() | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded. This filter is designed to operate on a list of elements visible in the given view. This can be obtained from a FilteredElementCollector constructed with the view id. This filter may not correctly restrict elements which are not a part of the visible elements of the view.