Finish Method


BRep Builder Finish Method

Complete construction of the geometry. The geometry will be validated and, if valid, stored in this BRepBuilder. Otherwise it will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public BRepBuilderOutcome Finish()

Return Value

BRepBuilderOutcome
BRepBuilderOutcome.Success if successful, BRepBuilderOutcome.Failure otherwise.
Exceptions
Exception Condition
InvalidOperationException This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details. -or- BRep doesn't have enough faces. -or- FinishFace() must be called on all the faces of the BRepBuilder.
Remarks
If this function returned anything but BRepBuilderOutcome.Success, this BrepBuilder object should be discarded. An attempt to retrieve the built b-rep via GetBRep() will cause an exception to be thrown.
See Also