IsBarMatchedWithShapeInReverseOrder Method


Rebar Free Form Accessor Is Bar Matched With Shape In Reverse Order Method

Checks if the bar at index barPositionIndex it's matched in reversed order with its shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsBarMatchedWithShapeInReverseOrder(
	int barPositionIndex
)

Parameters

barPositionIndex Int32
An index between 0 and (NumberOfBarPositions-1).

Return Value

Boolean
Returns true if the bar is matched in reversed order with its shape, false otherwise.
Exceptions
Exception Condition
ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ].
Remarks

If this Rebar has Workshop Instructions set to Straight will return false for all barPositionIndex between 0 and (NumberOfBarPositions-1).

If this Rebar has Workshop Instructions set to Bent there are different cases:

  • All bars are matched exactly with a shape. In this case will return false for all barPositionIndex between 0 and (NumberOfBarPositions-1).
  • All bars are matched in reversed order with a shape. In this case the Rebar will be reversed and will return false for all barPositionIndex between 0 and (NumberOfBarPositions-1).
  • Some bars are matched in reversed order and the others are matched exactly with a shape. For the bars matched in reversed order will return true and for the others will return false

See Also