SetGlobal2DDirectionHandles Method


Exporter IFCUtils Set Global 2DDirection Handles Method

Sets the handles representing the cardinal directions in 2D.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void SetGlobal2DDirectionHandles(
	bool positive,
	IFCAnyHandle xDir,
	IFCAnyHandle yDir
)

Parameters

positive Boolean
True if the handles returned should be in the positive direction, false if the handles should be in the negative direction.
xDir IFCAnyHandle
The X direction handle.
yDir IFCAnyHandle
The Y direction handle.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also