UpdaterRegistry Class


Updater Registry Class

An object that stores and manages all updaters registered in the current session.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB UpdaterRegistry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class UpdaterRegistry : IDisposable

The UpdaterRegistry type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member AddTrigger(UpdaterId, ElementFilter, ChangeType) Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
Public method Static member AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) Adds trigger with the specified element filter and ChangeType for the specified document
Public method Static member AddTrigger(UpdaterId, Document, ICollection ElementId , ChangeType) Adds a trigger to an updater with specified set of elements and ChangeType
Public method Static member DisableUpdater Disables the updater.
Public method Dispose Releases all resources used by the UpdaterRegistry
Public method Static member EnableUpdater Enables the updater.
Public method Static member GetIsUpdaterOptional Check if the updater is optional or not.
Public method Static member GetRegisteredUpdaterInfos Returns UpdaterInfos for all the application-wide updaters.
Public method Static member GetRegisteredUpdaterInfos(Document) Returns information about all updaters applicable to the given document.
Public method Static member IsUpdaterEnabled Checks if the updater is enabled or not.
Public method Static member IsUpdaterRegistered(UpdaterId) Checks whether updater with the given id is registered
Public method Static member IsUpdaterRegistered(UpdaterId, Document) Checks whether updater with the given id is registered in a document.
Public method Static member RegisterUpdater(IUpdater) Registers an updater application-wide, which means the updater may get triggered in any open document.
Public method Static member RegisterUpdater(IUpdater, Document) Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
Public method Static member RegisterUpdater(IUpdater, Boolean) Registers an updater application-wide, which means the updater may get triggered in any open document.
Public method Static member RegisterUpdater(IUpdater, Document, Boolean) Registers the updater for a specified document, which means the updater can only be triggered by changes made in that document.
Public method Static member RemoveAllTriggers Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
Public method Static member RemoveDocumentTriggers Removes all triggers associated with specified document and Updater Does not unregister updater.
Public method Static member SetExecutionOrder Forces execution order between two updaters Execution order: first before second
Public method Static member SetIsUpdaterOptional Sets a flag indicating whether an updater is optional or not.
Public method Static member UnregisterUpdater(UpdaterId) Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.
Public method Static member UnregisterUpdater(UpdaterId, Document) Unregisters an updater for the given document.
Top
Remarks

The registry is an application-wide singleton. It maintains all dynamic updaters currently registered, and also invokes them per their respective trigger condition during subsequent transactions.

Please note that only the application (an add-in, typically) which registered an updater is allowed to modify it later, including unregistering it. Also, an application is not allowed to register an updater with an Id, that is based on another application's Id.

See Also