Parameter As |
Get the parameter value as a string with units.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


String ShowValueParameterInformation(Parameter attribute)
{
string paramValue = null;
switch (attribute.StorageType)
{
case StorageType.Integer:
if (SpecTypeId.Boolean.YesNo
== attribute.Definition.GetDataType())
{
paramValue = null;
}
else
{
paramValue = attribute.AsValueString();
}
break;
case StorageType.Double:
paramValue = attribute.AsValueString();
break;
default:
paramValue = null;
break;
}
return paramValue;
}