IsValidShape Method (IList(GeometryObject))


Direct Shape Is Valid Shape(IList Geometry Object ) Method

Validates shape to be stored in a DirectShape. Supercedes and extends IsValidGeometry().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidShape(
	IList<GeometryObject> shape
)

Parameters

shape IList GeometryObject
Shape to be validated represented as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.

Return Value

Boolean
True if the supplied shape passes the validation criteria.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This function calls IsValidShape(GeometryObject) to validate each object in the list.
See Also