BuiltInFailures.ElectricityFailures Class


Built In Failures Electricity Failures Class

Failures related to electrical system and circuits.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures ElectricityFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ElectricityFailures

The BuiltInFailures ElectricityFailures type exposes the following members.

Properties
Name Description
Public property Static member FamilyMismatchCircuitDisconnected The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
Public property Static member InvalidPoleNumber The panel is single phase [wire] wires. The number of poles can not be larger than [value].
Public property Static member InvalidPoleNumberInIsolatedPanel The panel is an isolated panel. The number of poles should equal to [value].
Public property Static member InvalidSpareLoad The spare/space assigned to panel '[Panel Name]' has an invalid load property. To correct this issue, remove and add the spare/space to the panel again.
Top
See Also