SetMultiple Method


Parameter Set Multiple Method

Sets multiple parameters to new values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static List<Parameter> SetMultiple(
	IList<Tuple<Parameter, ParameterValue>> values
)

Parameters

values IList Tuple Parameter , ParameterValue
A list of pairs of parameters and their corresponding values.

Return Value

List Parameter
The list of parameters that were not set successfully, if any.
Exceptions
Exception Condition
InvalidOperationException The parameter is read-only.
ArgumentException Value must be a finite number.
Remarks
This method is provided as a performance optimization. Note that it will throw an exception if any parameter would throw an exception, so validate ahead of time.
See Also