Rebar |
This method creates a constraint of 'To Surface' type for a given RebarConstrainedHandle.
The RebarConstrainedHandle should belong to a shape driven rebar, otherwise it will throw exception.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static RebarConstraint CreateConstraintToSurface(
RebarConstrainedHandle handle,
Surface surface
)
Parameters
- handle RebarConstrainedHandle
- The handle of the rebar that will be constrained.
- surface Surface
- The surface that will be used by the constraint.
Return Value
RebarConstraintReturns the newly created RebarConstraint.

Exception | Condition |
---|---|
ArgumentException | handle is no longer valid. -or- Constrained rebar isn't a shape driven rebar element. -or- |
ArgumentNullException | A non-optional argument was null |